O que é o utilitário de rede do cliente de SQL Server?

O utilitário de rede do cliente de SQL Server é uma ferramenta gráfica que lhe permite:

  • Criar ligações de protocolo de rede a servidores específicos, assim como alterar o protocolo de rede predefinido.

  • Mostrar informações sobre as bibliotecas de rede actualmente instaladas no sistema.

  • Mostrar a versão da biblioteca de base de dados actualmente instalada no sistema e especificar predefinições para opções da biblioteca de base de dados.

Para mais informações sobre o utilitário de rede do cliente do servidor de SQL, consulte Managing Clients em SQL Server Books Online.

©1988-2000 Microsoft Corporation. Todos os direitos reservados.


General Tab

Envie-nos comentários acerca desta página Ajuda do Utilitário de rede do cliente

Separador Geral

Esta secção mostra as opções e respectivas funções disponíveis no separador Geral.

Opções

Protocolos desactivados

Indica quais são os protocolos disponíveis que não estão actualmente activados neste computador. Para activar um protocolo, clique no protocolo e, em seguida, clique em Activar.

Protocolos activados por ordem

Indica quais são os protocolos actualmente activados neste computador. Os protocolos são listados pela ordem em que o sistema os tentará utilizar para ligações.

Activar

Activa o protocolo actualmente realçado na lista Protocolos desactivados. Esta função também será executada se fizer duplo clique no protocolo.

Desactivar

Desactiva o protocolo actualmente realçado na lista Protocolos activados por ordem. Esta função também será executada se fizer duplo clique no protocolo.

Botões ‘Mover para cima’ e ‘Mover para baixo’

Move o protocolo realçado para cima e para baixo na lista. Isso permite-lhe alterar a ordem pela qual a biblioteca de rede tentará utilizar os protocolos para ligações.

Propriedades

Mostra as propriedades de ligação predefinidas do protocolo realçado.

Forçar encriptação de protocolos

Activa a encriptação de protocolos através de Secure Sockets Layer (SSL).

Activar protocolo de memória partilhada

Activa o protocolo de memória partilhada para ligações dentro do mesmo computador.

Tópicos relacionados

Como adicionar uma configuração de biblioteca de rede

Como eliminar uma configuração de biblioteca de rede

Como editar uma configuração de biblioteca de rede

Como verificar se o SQL Server está a receber em AppleTalk


Configuração do valor predefinido do protocolo de encaminhamentos designados

Esta secção mostra as opções e respectivas funções disponíveis na caixa de diálogo Configuração do valor predefinido do protocolo de rede para Encaminhamentos designados.

Opções

Encaminhamento predefinido

Especifique o encaminhamento predefinido que a biblioteca de rede de Encaminhamentos designados irá utilizar para tentar ligar à ocorrência de destino do Microsoft® SQL Server™.

Tópicos relacionados

Como adicionar uma configuração de biblioteca de rede

Como atribuir um alias a um encaminhamento alternativo

Como eliminar uma configuração de biblioteca de rede

Como editar uma configuração de biblioteca de rede


Configuração do valor predefinido do protocolo TCP/IP

Esta secção mostra as opções e respectivas funções disponíveis na caixa de diálogo Configuração do valor predefinido do protocolo de rede para TCP/IP

Opções

Porta predefinida

Especifique a porta predefinida que a biblioteca de rede de TCP/IP irá utilizar para tentar ligar à ocorrência de destino do Microsoft® SQL Server™. A predefinição é 1433.

Tópicos relacionados

Como adicionar uma configuração de biblioteca de rede

Como configurar um cliente para utilizar TCP/IP

Como eliminar uma configuração de biblioteca de rede

Como editar uma configuração de biblioteca de rede


Configuração do valor predefinido do protocolo Multiprotocolo

Esta secção mostra as opções e respectivas funções disponíveis na caixa de diálogo Configuração do valor predefinido do protocolo de rede para Multiprotocolo.

Opções

Protocolos RPC

Liste os protocolos que a biblioteca de rede Multiprotocolo irá utilizar para tentar ligar à ocorrência de destino do Microsoft® SQL Server™ A biblioteca de rede Multiprotocolo tentará cada protocolo pela ordem especificada até ser estabelecida uma ligação. Pode encontrar abaixo uma lista com nomes de protocolos individuais. Cada nome deve estar separado por um espaço.

Protocolo | Nome
Multiprotocolo | nlrpc
Encaminhamentos designados | nacn_np
TCP/IP | nacn_ip_tcp
IPX/SPX | nacn_spx

Tópicos relacionados

Como adicionar uma configuração de biblioteca de rede

Como configurar um cliente para utilizar a biblioteca de rede Multiprotocolo

Como eliminar uma configuração de biblioteca de rede

Como editar uma configuração de biblioteca de rede


Configuração do valor predefinido do protocolo NWLink IPX/SPX

Esta secção mostra as opções e respectivas funções disponíveis na caixa de diálogo Configuração do valor predefinido do protocolo de rede para NWLink IPX/SPX.

Opções

Rede predefinida

Especifique o número de rede NetWare. O valor predefinido é 0.

Porta predefinida

Especifique o número do socket. O valor predefinido é 33854.

Tópicos relacionados

Como adicionar uma configuração de biblioteca de rede

Como configurar um cliente para utilizar a biblioteca de rede NWLink IPX/SPX

Como eliminar uma configuração de biblioteca de rede

Como editar uma configuração de biblioteca de rede


Configuração do valor predefinido do protocolo AppleTalk

Esta secção mostra as opções e respectivas funções disponíveis na caixa de diálogo Configuração do valor predefinido do protocolo de rede para AppleTalk.

Opções

Zona predefinida

Especifique a zona utilizada quando registar o serviço.

Tópicos relacionados

Como adicionar uma configuração de biblioteca de rede

Como configurar um cliente para utilizar a biblioteca de rede AppleTalk

Como eliminar uma configuração de biblioteca de rede

Como editar uma configuração de biblioteca de rede


Configuração do valor predefinido do protocolo Banyan VINES

Esta secção mostra as opções e respectivas funções disponíveis na caixa de diálogo Configuração do valor predefinido do protocolo de rede para Banyan VINES.

Opções

Grupo predefinido

Especifique o grupo a que o serviço pertence.

Organização predefinida

Especifique a organização a que o grupo pertence.

Tópicos relacionados

Como adicionar uma configuração de biblioteca de rede

Como configurar um cliente para utilizar a biblioteca de rede Banyan VINES

Como eliminar uma configuração de biblioteca de rede

Como editar uma configuração de biblioteca de rede


Configuração do valor predefinido do protocolo VIA

Esta secção mostra as opções e respectivas funções disponíveis na caixa de diálogo Configuração do valor predefinido do protocolo de rede para VIA.

Opções

Fornecedor

Especifique o fornecedor de hardware a ser utilizado com o protocolo VIA.

Porta do servidor predefinida

Especifique a porta do servidor predefinida. O valor predefinido é 0:1433.

NIC de cliente predefinida

Especifique a placa de interface de rede de cliente predefinida. O valor predefinido é 0.

Tópicos relacionados

Como adicionar uma configuração de biblioteca de rede

Como eliminar uma configuração de biblioteca de rede

Como editar uma configuração de biblioteca de rede


Separador Alias

Esta secção mostra as opções e respectivas funções disponíveis no separador Alias.

Opções

Configurações de alias do servidor

Lista informações sobre os nomes alternativos dos computadores a que o cliente está a ligar.

Alias do servidor

Indica o nome alternativo do servidor utilizado para o computador a que o cliente está a ligar.

Biblioteca de rede

Indica a biblioteca de rede do cliente utilizada para a entrada de configuração.

Parâmetros de ligação

Indica os parâmetros associados ao endereço de ligação da configuração de biblioteca de rede.

Adicionar

Adiciona uma nova configuração de biblioteca de rede.

Remover

Remove uma configuração de biblioteca de rede.

Editar

Edita uma configuração de biblioteca de rede.

Tópicos relacionados

Como adicionar uma configuração de biblioteca de rede

Como eliminar uma configuração de biblioteca de rede

Como editar uma configuração de biblioteca de rede

Como verificar se o SQL Server está a receber em AppleTalk


Adicionar (ou editar) configuração de biblioteca de encaminhamentos designados

Esta secção mostra as opções e respectivas funções disponíveis na caixa de diálogo Adicionar (ou editar) configuração de biblioteca de rede para Encaminhamentos designados.

Opções

Alias do servidor

Especifique um nome exclusivo para a ocorrência do Microsoft® SQL Server™ que recebe na biblioteca de rede Encaminhamentos designados.

Bibliotecas de rede

Especifique a biblioteca de rede que será utilizada para ligar ao servidor. Encaminhamentos designados está seleccionada.

Nome do servidor

Especifique o nome do servidor da ocorrência de destino do SQL Server.

Nome do encaminhamento

Especifique o encaminhamento que a biblioteca de rede Encaminhamentos designados irá utilizar para tentar ligar à ocorrência de destino do SQL Server.

Tópicos relacionados

Como adicionar uma configuração de biblioteca de rede

Como atribuir um alias a um encaminhamento alternativo

Como eliminar uma configuração de biblioteca de rede

Como editar uma configuração de biblioteca de rede


Adicionar (ou editar) configuração de biblioteca TCP/IP

Esta secção mostra as opções e respectivas funções disponíveis na caixa de diálogo Adicionar (ou editar) configuração de biblioteca de rede para TCP/IP.

Opções

Alias do servidor

Especifique um nome exclusivo para o servidor que executa uma ocorrência do Microsoft® SQL Server™ que recebe na biblioteca de rede Sockets de TCP/IP.

Bibliotecas de rede

Especifique a biblioteca de rede que será utilizada para ligar ao servidor. TCP/IP está seleccionado.

Nome do servidor

Especifique a ocorrência do SQL Server que recebe clientes de Sockets de TCP/IP.

Determinar porta dinamicamente

Especifique que a biblioteca de rede irá determinar a porta dinamicamente. A porta especificada em Número da porta não será utilizada.

Número da porta

Especifique a porta que a biblioteca de rede TCP/IP irá utilizar para tentar ligar à ocorrência de destino do SQL Server. A predefinição é 1433, o número da porta que a biblioteca de rede Sockets do Windows normalmente utiliza para o SQL Server. Na maior parte dos casos, utilize o número de porta predefinido. Este campo só está activo quando a caixa de verificação Determinar porta dinamicamente está desmarcada.

Tópicos relacionados

Como adicionar uma configuração de biblioteca de rede

Como configurar um cliente para utilizar TCP/IP

Como eliminar uma configuração de biblioteca de rede

Como editar uma configuração de biblioteca de rede


Adicionar (ou editar) configuração de biblioteca Multiprotocolo

Esta secção mostra as opções e respectivas funções disponíveis na caixa de diálogo Adicionar (ou editar) configuração de biblioteca de rede para Multiprotocolo.

Opções

Alias do servidor

Especifique um nome exclusivo para o servidor que executa uma ocorrência do Microsoft® SQL Server™ que recebe na biblioteca de rede Multiprotocolo.

Bibliotecas de rede

Especifique a biblioteca de rede que será utilizada para ligar ao servidor. Multiprotocolo está seleccionada.

Nome do servidor

Especifique a ocorrência do SQL Server que recebe clientes de Multiprotocolo.

Parâmetros adicionais

Especifique parâmetros de configuração adicionais para a biblioteca de rede Multiprotocolo. Estes parâmetros são opcionais.

Tópicos relacionados

Como adicionar uma configuração de biblioteca de rede

Como configurar um cliente para utilizar a biblioteca de rede Multiprotocolo

Como eliminar uma configuração de biblioteca de rede

Como editar uma configuração de biblioteca de rede


Adicionar (ou editar) a configuração da biblioteca de rede NWLink IPX/SPX (nome do serviço)

Esta secção mostra as opções e respectivas funções disponíveis na caixa de diálogo Adicionar (ou editar) configuração de biblioteca de rede para NWLink IPX/SPX.

Opções

Alias do servidor

Especifique um nome exclusivo para o servidor que executa uma ocorrência do Microsoft® SQL Server™ que recebe na biblioteca de rede NWLink IPX/SPX.

Bibliotecas de rede

Especifique a biblioteca de rede que será utilizada para ligar ao servidor. NWLink IPX/SPX está seleccionado.

Especificar parâmetros por

Indique como os parâmetros são especificados. Nome do serviço está seleccionado.

Nome do serviço

Especifique o nome do computador com o Microsoft Windows NT® 4.0 ou o Windows® 2000 em que está a ser executada uma ocorrência do SQL Server. Esta informação é armazenada no enlace do servidor.

Tópicos relacionados

Como adicionar uma configuração de biblioteca de rede

Como configurar um cliente para utilizar a biblioteca de rede NWLink IPX/SPX

Como eliminar uma configuração de biblioteca de rede

Como editar uma configuração de biblioteca de rede


Adicionar (ou editar) a configuração da biblioteca de rede NWLink IPX/SPX (endereço de rede)

Esta secção mostra as opções e respectivas funções disponíveis na caixa de diálogo Adicionar (ou editar) configuração de biblioteca de rede para NWLink IPX/SPX.

Opções

Alias do servidor

Especifique um nome exclusivo para o servidor que executa uma ocorrência do Microsoft® SQL Server™ que recebe na biblioteca de rede NWLink IPX/SPX.

Bibliotecas de rede

Especifique a biblioteca de rede que será utilizada para ligar ao servidor. NWLink IPX/SPX está seleccionado.

Especificar parâmetros por

Indique como os parâmetros são especificados. Endereço de rede está seleccionado.

Endereço

Especifique o endereço MAC.

Porta

Especifique o número do socket. O valor predefinido é 33854.

Rede

Especifique o número de rede NetWare. O valor predefinido é 0.

Tópicos relacionados

Como adicionar uma configuração de biblioteca de rede

Como configurar um cliente para utilizar a biblioteca de rede NWLink IPX/SPX

Como eliminar uma configuração de biblioteca de rede

Como editar uma configuração de biblioteca de rede


Adicionar (ou editar) configuração de biblioteca AppleTalk

Esta secção mostra as opções e respectivas funções disponíveis na caixa de diálogo Adicionar (ou editar) configuração de biblioteca de rede para AppleTalk.

Opções

Alias do servidor

Especifique um nome exclusivo para o servidor que executa uma ocorrência do Microsoft® SQL Server™ que recebe na biblioteca de rede AppleTalk.

Bibliotecas de rede

Especifique a biblioteca de rede que será utilizada para ligar ao servidor. AppleTalk está seleccionada.

Nome do objecto

Especifique o objecto de serviço atribuído pelo administrador do sistema.

Zona

Especifique a zona utilizada quando registar o serviço.

Tópicos relacionados

Como adicionar uma configuração de biblioteca de rede

Como configurar um cliente para utilizar a biblioteca de rede AppleTalk

Como eliminar uma configuração de biblioteca de rede

Como editar uma configuração de biblioteca de rede


Adicionar (ou editar) configuração de biblioteca Banyan VINES

Esta secção mostra as opções e respectivas funções disponíveis na caixa de diálogo Adicionar (ou editar) configuração de biblioteca de rede para Banyan VINES.

Opções

Alias do servidor

Especifique um nome exclusivo para o servidor que executa uma ocorrência do Microsoft® SQL Server™ que recebe utilizando a biblioteca de rede Banyan VINES.

Bibliotecas de rede

Especifique a biblioteca de rede que será utilizada para ligar ao servidor. Banyan VINES está seleccionado.

Serviço

Especifique o nome de serviço StreetTalk baseado no computador utilizado pelo servidor.

Grupo

Especifique o grupo a que o serviço pertence.

Organização

Especifique a organização a que o grupo pertence.

Tópicos relacionados

Como adicionar uma configuração de biblioteca de rede

Como configurar um cliente para utilizar a biblioteca de rede Banyan VINES

Como eliminar uma configuração de biblioteca de rede

Como editar uma configuração de biblioteca de rede


Adicionar (ou editar) configuração de biblioteca VIA

Esta secção mostra as opções e respectivas funções disponíveis na caixa de diálogo Adicionar (ou editar) configuração de biblioteca de rede para VIA.

Opções

Alias do servidor

Especifique um nome exclusivo para o servidor que executa uma ocorrência do Microsoft® SQL Server™ que recebe utilizando a biblioteca de rede VIA.

Bibliotecas de rede

Especifique a biblioteca de rede que será utilizada para ligar ao servidor. VIA está seleccionada.

Nome do servidor

Especifique a ocorrência do SQL Server que recebe clientes de VIA.

Número de porta do servidor

Especifique o número de porta do servidor a utilizar quando ligar à ocorrência do SQL Server. A predefinição é 0:1433.

Tópicos relacionados

Como adicionar uma configuração de biblioteca de rede

Como eliminar uma configuração de biblioteca de rede

Como editar uma configuração de biblioteca de rede


Adicionar (ou editar) outras configurações de bibliotecas

Esta secção mostra as opções e respectivas funções disponíveis na caixa de diálogo Adicionar (ou editar) configuração de biblioteca de rede para outros protocolos.

Opções

Alias do servidor

Especifique um nome exclusivo para o servidor que executa uma ocorrência do Microsoft® SQL Server™ que recebe utilizando a nova configuração de biblioteca de rede.

Bibliotecas de rede

Especifique a biblioteca de rede que será utilizada para ligar ao servidor. Outras está seleccionado.

Nome de ficheiro

Especifique o nome e a localização da DLL da biblioteca de rede fornecida por terceiros.

Parâmetros

Especifique os parâmetros necessários e o respectivo formato.

Tópicos relacionados

Como adicionar uma configuração de biblioteca de rede

Como configurar um cliente para utilizar uma biblioteca de rede que não seja padrão

Como eliminar uma configuração de biblioteca de rede

Como editar uma configuração de biblioteca de rede


Separador Opções da biblioteca de base de dados

Esta secção mostra as opções e respectivas funções disponíveis no separador Opções da biblioteca de base de dados.

Opções

Nome de ficheiro

Indica o nome e a localização do ficheiro da biblioteca de base de dados instalada neste computador.

Versão

Indica o número da versão da biblioteca de base de dados instalada neste computador.

Data

Indica a data em que a biblioteca de base de dados foi instalada neste computador.

Tamanho

Indica o tamanho do ficheiro da biblioteca de base de dados instalada neste computador.

Conversão ANSI para OEM automática

Permite à biblioteca de base de dados converter um conjunto de caracteres de OEM para ANSI quando comunicar com o Microsoft® SQL Server™ a partir do cliente e de ANSI para OEM quando comunicar com o cliente a partir do SQL Server. Seleccionado por predefinição.

Utilizar definições internacionais

Permite à biblioteca de base de dados obter formatos de data, hora e moeda no sistema, em vez de utilizar parâmetros codificados. Seleccionado por predefinição para os clientes executados em sistema operativos Microsoft Windows® de 32 bits.

Tópicos relacionados

Como definir preferências de conversão da biblioteca de base de dados


Separador Bibliotecas de rede

Esta secção mostra as opções e respectivas funções disponíveis no separador Bibliotecas de rede.

Opções

Biblioteca de rede

Lista as bibliotecas de rede do cliente de Microsoft® SQL Server™ instaladas neste computador.

Nome do ficheiro da biblioteca

Lista a localização das bibliotecas de rede do cliente de SQL Server instaladas neste computador.

Versão

Lista os números de versão das bibliotecas de rede do cliente de SQL Server instaladas neste computador.

Data do ficheiro

Lista as datas em que as bibliotecas de rede do cliente de SQL Server foram instaladas neste computador.

Tamanho

Lista os tamanhos dos ficheiros das bibliotecas de rede do cliente de SQL Server instaladas neste computador.

Tópicos relacionados

Como mostrar os números de versão de bibliotecas


Gerir clientes

Um cliente é uma aplicação terminal que utiliza os serviços fornecidos por um servidor. O computador que tem a aplicação é referido como o computador cliente. O software cliente permite aos computadores ligar a uma ocorrência do Microsoft® SQL Server™ numa rede.

Os clientes do servidor de SQL podem incluir aplicações de vários tipos, como, por exemplo:

  • Consumidores de OLE DB.

    Estas aplicações utilizam o fornecedor de Microsoft OLE DB para SQL Server ou o fornecedor de Microsoft OLE DB para ODBC para ligar e comunicar com ocorrências do SQL Server. Os fornecedores de OLE DB servem como intermediários entre uma ocorrência do SQL Server e aplicações cliente que consumam dados do SQL Server como conjuntos de linhas de OLE DB.

  • Aplicações de ODBC.

    Estas incluem utilitários cliente instalados com o SQL Server, como, por exemplo, o SQL Server Enterprise Manager e o SQL Query Analyzer, assim como outras aplicações que utilizem o controlador de ODBC para SQL Server para ligar e comunicar com o SQL Server.

  • Clientes da biblioteca de base de dados, incluindo o utilitário de linha de comandos isql do SQL Server e clientes escritos para a biblioteca de base de dados.

Independentemente do tipo de aplicação, a gestão de um cliente consiste principalmente em configurar a respectiva ligação com os componentes servidores do SQL Server. Dependendo dos requisitos do site, a gestão de clientes pode ir desde uma simples introdução do nome do computador servidor a criar uma biblioteca de entradas de configuração para dar resposta a um ambiente de vários servidores diversos.


Como iniciar o Utilitário de rede do cliente (Windows)

Para iniciar o Utilitário de rede do cliente

  • No menu Iniciar, aponte para Programas/Microsoft SQL Server e, em seguida, clique em Utilitário de rede do cliente.


Como visualizar os números de versão de bibliotecas de rede (Utilitário de rede do cliente)

Para visualizar os números de versão de bibliotecas

  • Clique no separador Bibliotecas de rede.

    São mostrados a biblioteca de rede, o nome do ficheiro de biblioteca, a versão, a data do ficheiro e o tamanho.


Como definir as preferências de conversão da biblioteca de base de dados (Utilitário de rede do cliente)

Nota Este procedimento aplica-se a clientes do sistema operativo Microsoft® Windows® de 32 bits.

Para definir preferências de conversão da biblioteca de bases de dados

  1. Clique no separador Opções da biblioteca de base de dados.

  2. Seleccione ou desmarque a caixa de verificação Conversão ANSI para OEM automática.

  3. Seleccione ou desmarque a caixa de verificação Utilizar definições internacionais.


Como adicionar uma configuração de biblioteca de rede (Utilitário de rede do cliente)

Para adicionar uma configuração de biblioteca de rede.

  1. Clique no separador Alias e, em seguida, clique em Adicionar.

  2. Na caixa de diálogo Adicionar configuração de biblioteca de rede, em Bibliotecas de rede, seleccione uma das bibliotecas de rede.

  3. Introduza o alias do servidor, assim como as informações de parâmetros necessárias para a biblioteca de rede seleccionada.


Como editar uma configuração de biblioteca de rede (Utilitário de rede do cliente)

Para editar uma configuração de biblioteca de rede.

  1. Clique no separador Alias e, em seguida, clique na configuração do protocolo de rede a editar.

  2. Clique em Editar.

  3. Na caixa de diálogo Editar configuração de biblioteca de rede, edite as informações a alterar.


Como eliminar uma configuração de biblioteca de rede (Utilitário de rede do cliente)

Para eliminar uma configuração de biblioteca de rede.

  1. Clique no separador Alias e, em seguida, clique na configuração de biblioteca de rede a eliminar.

  2. Clique em Remover.


Como atribuir um alias de cliente a um encaminhamento alternativo (Utilitário de rede do cliente)

Para atribuir o alias de um cliente a um encaminhamento alternativo

  1. Clique no separador Alias e, em seguida, clique em Adicionar.

  2. Na caixa de diálogo Adicionar configuração de biblioteca de rede, clique em Encaminhamentos designados.

  3. Na caixa Alias do servidor, introduza o alias do servidor.

  4. Em Parâmetros de ligação, na caixa Nome do encaminhamento, escreva o nome do encaminhamento alternativo (por exemplo, \\omeuservidor\encaminhamento\encaminhamentoalt).


Como configurar um cliente para utilizar a biblioteca de rede Multiprotocolo (Utilitário de rede do cliente)

Nota Antes de criar uma configuração de cliente multiprotocolo, certifique-se de que o computador tem, pelo menos, um protocolo IPC carregado em Multiprotocolo no servidor (Encaminhamentos designados, NWLink IPX/SPX, TCP/IP ou Sockets do Windows).

Para configurar um cliente para utilizar a biblioteca de rede Multiprotocolo

  1. Clique no separador Alias e, em seguida, clique em Adicionar.

  2. Na caixa de diálogo Adicionar configuração de biblioteca de rede, clique em Multiprotocolo.

  3. Na caixa Alias do servidor, introduza o nome da ocorrência do Microsoft® SQL Server™ que recebe na biblioteca de rede Multiprotocolo.

  4. Deixe a caixa Parâmetros adicionais em branco, salvo se o servidor necessitar de parâmetros específicos. Confirme com o administrador da rede antes de introduzir parâmetros.


Como configurar um cliente para utilizar TCP/IP (Utilitário de rede do cliente)

Para configurar um cliente para utilizar TCP/IP

  1. Clique no separador Geral e, em seguida, clique em Adicionar.

  2. Na caixa de diálogo Adicionar configuração de biblioteca de rede, clique em TCP/IP.

  3. Na caixa Alias do servidor, introduza o alias da ocorrência do Microsoft® SQL Server™ que recebe na biblioteca de rede Windows Sockets.

    Com o TCP/IP, também pode especificar o servidor com o respectivo endereço IP em vez do nome.

  4. Efectue um dos seguintes procedimentos:
    • Seleccione a caixa de verificação Determinar porta dinamicamente para determinar automaticamente a porta.

    • Desmarque a caixa de verificação Determinar porta dinamicamente para definir a porta manualmente e, em seguida, na caixa Número da porta, escreva o número da porta.

Para mais informações sobre outros protocolos de TCP/IP que suportem Windows Sockets, consulte a documentação do TCP/IP.


Como configurar um cliente para utilizar a biblioteca de rede NWLink IPX/SPX (Utilitário de rede do cliente)

Para configurar um cliente para utilizar a biblioteca de rede NWLink IPX/SPX

  1. Clique no separador Alias e, em seguida, clique em Adicionar.

  2. Na caixa de diálogo Adicionar configuração de biblioteca de rede, clique em NWLink IPX/SPX.

  3. Na caixa Alias do servidor, introduza o alias da ocorrência do Microsoft® SQL Server™ que recebe na biblioteca de rede NWLink IPX/SPX.

  4. Em Parâmetros de ligação, clique em Nome do serviço ou em Endereço de rede e, em seguida, efectue um dos seguintes procedimentos:
    • Se clicou em Nome do serviço, introduza o nome do serviço.

      Nome do serviço é o nome do computador com o Microsoft Windows NT® 4.0 ou o Windows® 2000 em que está a ser executada uma ocorrência do SQL Server. Este nome é armazenado no Enlace do computador servidor.

    • Se clicou em Endereço de rede, introduza o endereço (o endereço MAC), a porta (número do socket) e a rede (número da rede NetWare).


Como configurar um cliente para utilizar a biblioteca de rede AppleTalk (Utilitário de rede do cliente)

Para configurar um cliente para utilizar a biblioteca de rede AppleTalk

  1. Clique no separador Alias e, em seguida, clique em Adicionar.

  2. Na caixa de diálogo Adicionar configuração de biblioteca de rede, clique em AppleTalk.

  3. Na caixa Alias do servidor, introduza o nome da ocorrência do Microsoft® SQL Server™ que recebe na biblioteca de rede AppleTalk.

  4. Em Parâmetros de ligação, escreva o nome de objecto AppleTalk e identificadores de zona opcionais.


Como configurar um cliente para utilizar a biblioteca de rede Banyan VINES (Utilitário de rede do cliente)

Para configurar um cliente para utilizar a biblioteca de rede Banyan VINES

  1. Clique no separador Alias e, em seguida, clique em Adicionar.

  2. Na caixa de diálogo Adicionar configuração de biblioteca de rede, clique em Banyan VINES.

  3. Na caixa Alias do servidor, introduza o alias da ocorrência do Microsoft® SQL Server™ que recebe na biblioteca de rede Banyan VINES.

  4. Em Parâmetros de ligação, escreva o serviço e a organização VINES. Pode utilizar o valor predefinido de MSSQL para o grupo.


Como configurar um cliente para utilizar a biblioteca de rede VIA (Utilitário de rede do cliente)

Para configurar um cliente para utilizar a biblioteca de rede VIA

  1. Clique no separador Alias e, em seguida, clique em Adicionar.

  2. Na caixa de diálogo Adicionar configuração de biblioteca de rede, clique em VIA.

  3. Na caixa Alias do servidor, introduza o alias da ocorrência do Microsoft® SQL Server™ que recebe na biblioteca de rede VIA.

  4. Em Parâmetros de ligação, escreva o nome do servidor e o número da porta do servidor.


Como configurar um cliente para utilizar uma biblioteca de rede que não seja padrão (Utilitário de rede do cliente)

Para configurar um cliente para utilizar uma biblioteca de rede que não seja padrão

  1. Clique no separador Alias e, em seguida, clique em Adicionar.

  2. Na caixa de diálogo Adicionar configuração de biblioteca de rede, clique em Outras.

  3. Na caixa Alias do servidor, introduza o alias da ocorrência do Microsoft® SQL Server™ que recebe na biblioteca de rede que pretende instalar.

  4. Em Parâmetros de ligação, escreva o nome do ficheiro (o ficheiro tem de ser uma DLL) da biblioteca de rede instalada. Não introduza a extensão da DLL.

  5. Se necessário, introduza informações adicionais na caixa Parâmetros (por exemplos, o nome de utilizador e a palavra-passe). Utilize vírgulas como separadores entre os parâmetros.


Como verificar se o SQL Server está a receber em AppleTalk e se pode aceitar uma ligação ao cliente (Utilitário de rede do cliente)

Para verificar se o SQL Server está a receber em AppleTalk e se pode aceitar uma ligação ao cliente

  1. Copie a biblioteca de rede AppleTalk do cliente (Dbmsadsn.dll) do directório \WINNT\system32 do servidor para o mesmo directório de um computador remoto com o Microsoft® Windows NT® ou o Microsoft Windows® 2000 Services para Macintosh.

  2. Na estação de trabalho remota, inicie a configuração do cliente de SQL Server.

  3. Se AppleTalk estiver na lista Protocolos desactivados, clique em AppleTalk e, em seguida, clique em Activar.

  4. Na lista Protocolos activados por ordem, clique em AppleTalk e, em seguida, clique no botão para cima até que AppleTalk esteja no topo da lista.

  5. Clique em OK.

  6. Tente uma ligação de ISQL ao nome do objecto do serviço AppleTalk.

    Por exemplo, na linha de comandos, escreva:

    isql -Usa -P -Snomedoserviço

    Se for possível ligar a ISQL e efectuar consultas, o servidor estará correctamente configurado e a aceitar ligações.

    Nota A biblioteca de rede AppleTalk (Dbmsadsn.dll) do lado do cliente de Microsoft Win32® (ADSP) está incluída para testar ligações ADSP e resolver problemas de ligações AppleTalk entre clientes Macintosh e Microsoft SQL Server™. Esta biblioteca de rede destina-se a ser utilizada apenas durante o teste de uma ligação de um cliente remoto a uma ocorrência do SQL Server. Se tentar efectuar ligações locais através da biblioteca de rede ADSP a uma ocorrência do SQL Server que receba em AppleTalk, ocorrerá o seguinte erro de rede: Net-Library error 11: getsockopt().


Como verificar a versão do controlador de ODBC para SQL Server (Windows)

Nota Só pode seguir estes passos se estiver a executar o sistema operativo Microsoft® Windows NT® 4.0.

Para verificar a versão do controlador de ODBC para SQL Server (ODBC de 32 bits)

  1. No Painel de controlo, clique duas vezes em Origens de dados ODBC.

  2. Clique no separador Controladores.

    As informações da entrada Microsoft SQL Server™ são apresentadas na coluna Versão.


Copyright e exclusão de responsabilidade do Microsoft SQL Server 2000

Este documento, incluindo as aplicações exemplo, destina-se apenas a fins informativos e a Microsoft não concede nenhuma garantia, expressa ou implícita, neste documento. As informações contidas neste documento, incluindo exemplos, URLs e outras referências a Web sites da Internet, estão sujeitas a alterações sem aviso prévio. Todos os riscos de utilização ou dos resultados da utilização deste documento são da responsabilidade do utilizador.

O objectivo principal de um exemplo consiste em ilustrar um conceito ou uma utilização aceitável de uma determinada instrução ou cláusula. A maior parte dos exemplos não inclui a totalidade do código que seria normalmente encontrado num sistema completo, dado que muita da habitual validação de dados e do tratamento de erros é removido para destacar no exemplo um determinado conceito ou uma instrução. Não está disponível suporte técnico para estes exemplos ou para o código fonte fornecido.

Os nomes de empresas, organizações, produtos, pessoas e eventos mencionados neste documento são fictícios e não se destinam, de todo, a representar qualquer empresa, organização, produto, pessoa ou evento real, salvo indicação em contrário. A conformidade com todas as leis de copyright aplicáveis é da inteira responsabilidade do utilizador. Sem limitação dos direitos protegidos por copyright, nenhuma parte desta publicação deverá ser reproduzida, armazenada ou introduzida num sistema de recuperação ou transmitida de alguma forma ou por qualquer meio (electrónico, mecânico, através de fotocópia, gravação ou outros) ou para qualquer finalidade, sem a permissão por escrito da Microsoft Corporation.

Nesta publicação, a Microsoft pode ter patentes, pedidos de patente pendentes, marcas comerciais, copyrights ou outros direitos de propriedade intelectual. Com excepção do estipulado expressamente em qualquer acordo de licenças escrito pela Microsoft, o facto de este documento lhe ser fornecido não lhe confere quaisquer direitos sobre essas patentes, marcas comerciais, copyrights ou outras formas de propriedade intelectual.

©1996-2000 Microsoft Corporation. Todos os direitos reservados.

Active Directory, ActiveX, BackOffice, CodeView, Developer Studio, FoxPro, JScript, Microsoft, Microsoft Press, Microsoft SQL Server, MSDN, MS-DOS, Outlook, PivotChart, PivotTable, PowerPoint, Visual Basic, Visual C++, Visual Studio, Win32, Windows 2000, Windows e Windows NT são marcas registadas ou comerciais da Microsoft Corporation nos Estados Unidos e/ou noutros países.

Os nomes das empresas e produtos reais mencionados nesta publicação podem ser marcas comerciais dos respectivos proprietários.

Versão: 8.00.000


Envie-nos comentários acerca desta página Ajuda do Utilitário de rede do cliente

Consulte SQL Server Books Online para rever este tópico.

©1988-2000 Microsoft Corporation. Todos os direitos reservados.